0
0
Fork 0
Our blog as a set of static pages. http://zero-knowledge.org
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
zblog/content/post/14.md

21 lines
829 B

+++
title = "Rails mit Problemen unter OpenSolaris"
date = "2009-08-31T06:09:00+00:00"
author = "Gibheer"
draft = false
+++
Und wieder zeigt sich, dass opensolaris etwas anders tickt als Linux.
Ich hab gestern mal Ruby on Rails installiert und brauchte für eine
bestimmte Software die Version 2.2.2 In dieser Version hat Activesupport
einen
[Bug](https://rails.lighthouseapp.com/projects/8994/tickets/1396-framework-crashes-on-launch-on-solaris-with-invalid-encoding-asciiignoretranslit-utf-8),
der nur unter opensolaris zu tage tritt. In dem fehlerhaften Teil soll
das Encoding konvertiert werden, allerdings von einem Encoding, welches
unter opensolaris nicht existiert.
Mit Rails 2.3 soll das Problem allerdings behoben sein. Die Version
2.2.3, die in der Bugmeldung angesprochen wird, gibt es uebrigens (noch)
nicht.